Cloud Backup Web Console

Incident Report for METROFILE CLOUD KENYA

Resolved

Issue has been resolved
Posted Sep 23, 2024 - 08:50 UTC

Investigating

We are currently investigating a Web Console outage from our Service Provider
Posted Sep 23, 2024 - 07:46 UTC
This incident affected: Cloud Backup (Cloud Backup Web Console).