Internet Connectivity Outage

Incident Report for METROFILE CLOUD KENYA

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 07:03 UTC

Identified

We are currently investigating a data centre internet outage at our Kenya DC. The outage lasted an estimated 45 minutes before connectivity was restored.

We are currently investigating with the Data Centre team.
Posted Aug 22, 2025 - 07:26 UTC
This incident affected: Cloud Backup (Cloud Backup Storage) and Hosting, Cloud Vault S3.