Backup Web Console Incident

Incident Report for METROFILE CLOUD KENYA

Resolved

The incident has been resolved and the console is online.
Posted Jan 26, 2025 - 19:11 UTC

Investigating

We are currently investigating a web console outage.
Posted Jan 26, 2025 - 13:44 UTC
This incident affected: Cloud Backup (Cloud Backup Web Console).