Power Outage during DC Upgrade

Incident Report for METROFILE CLOUD KENYA

Postmortem


Resolved

We are currently happy that systems are healthy and online, we will be closing this incident out for now.

Please contact vps@metrofilecloud.com if you require the RCA once its available.
Posted Jul 15, 2025 - 07:56 UTC

Monitoring

We have implemented a fix and connectivity has been restored. Please test and if you have any issues, please contact vps@metrofilecloud.com.
Posted Jul 14, 2025 - 20:42 UTC

Identified

Power has been restored at the Data Centre, we are busy troubleshooting connectivity issues.
Posted Jul 14, 2025 - 20:11 UTC

Investigating

We are investigating a total outage of our services in Kenya with the Data Centre team
Posted Jul 14, 2025 - 14:41 UTC
This incident affected: Cloud Backup (Cloud Backup Storage) and Hosting, Cloud Vault S3.